Error. '> ' is an unexpected token

View previous topic View next topic Go down

Error. '> ' is an unexpected token

Post by PCPIMP on Thu Feb 04, 2010 2:31 pm

Can anyone please help me with this error? Error. '>
' is an unexpected token. The expected token is ''or'' line 6 position 62 When I first configed app it worked once I rebooted this is the error I started getting.

PCPIMP

Posts : 1
Join date : 2010-02-04

View user profile

Back to top Go down

Re: Error. '> ' is an unexpected token

Post by admin on Thu Feb 04, 2010 5:05 pm

Yes, I've seen this myself. I'm pretty sure it's a bug somewhere in a URL or XML parser buried in the Exchange Web Services.

It seems to be triggered when one or more 'special' characters are contained in the subject line of an email. I suspect the following,


  • Ampersand (&
    )[/*Ⓜ1acyy]
  • Angle bracket (<
    or >
    )[/*Ⓜ1acyy]
  • Quotation mark ("
    )[/*Ⓜ1acyy]
  • Apostrophe (')[/*Ⓜ1acyy]


I will do some testing and see if I can figure out what is going on.
avatar
admin
Field Marshal
Field Marshal

Posts : 310
Join date : 2009-08-27
Age : 48
Location : Scotland

View user profile http://www.owatray.com

Back to top Go down

Re: Error. '> ' is an unexpected token

Post by admin on Thu Feb 04, 2010 5:23 pm

Maybe not.
I don't seem able to force this error no matter what characters I use.

I am now suspecting the URL as the probable cause. Please double-check all your settings and re-try.

If still not working please feel free to PM me with your details and I'd be happy to look at this for you.
avatar
admin
Field Marshal
Field Marshal

Posts : 310
Join date : 2009-08-27
Age : 48
Location : Scotland

View user profile http://www.owatray.com

Back to top Go down

Re: Error. '> ' is an unexpected token

Post by christianbobsin on Wed Jun 30, 2010 8:18 pm

Hi Admin

The Same error happen when I try use the OwaTray. I'm from Brazil and we have a lot of Special Characters! like ã á é í o õ ü this can cause the error ?

christianbobsin

Posts : 1
Join date : 2010-06-30

View user profile

Back to top Go down

Re: Error. '> ' is an unexpected token

Post by admin on Thu Jul 01, 2010 2:23 pm

I'm sorry, I don't have fix for this.

I'm certain that the XML being created by EWS is somehow getting malformed and the XML parser is throwing the error.
I really can't see a way around it for the moment.
avatar
admin
Field Marshal
Field Marshal

Posts : 310
Join date : 2009-08-27
Age : 48
Location : Scotland

View user profile http://www.owatray.com

Back to top Go down

Re: Error. '> ' is an unexpected token

Post by kspainter on Thu Jul 22, 2010 8:32 pm

I am also getting Error. '>
' is an unexpected token. The expected token is "
"
or "
"
. Line 6, position 62.

Not connected to Exchange.

.net version 4

kspainter

Posts : 1
Join date : 2010-07-22

View user profile

Back to top Go down

Re: Error. '> ' is an unexpected token

Post by admin on Tue Aug 03, 2010 5:39 pm

What I really need from you guys is access to an email account that is displaying this kind of error.

If anyone can give me temporary access then I can debug the issue from my end and sort this out.

PM me if you can help. geek
avatar
admin
Field Marshal
Field Marshal

Posts : 310
Join date : 2009-08-27
Age : 48
Location : Scotland

View user profile http://www.owatray.com

Back to top Go down

Re: Error. '> ' is an unexpected token

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum